SCS West Parallels Client Security Notification
Incident Report for SWK Technologies Systems
Resolved
Parallels has located the issue and applied a fix. We have tested the fix and should not see the issue with the current version of the client.
Thank you again for your patience.

MCS Team
Posted Oct 12, 2020 - 14:58 EDT
Update
IDENTIFIED
If an alert is received regarding your Secure Cloud Services Parallels connection not being secure:

We have identified an issue with the latest version of the Parallels client and are currently awaiting a fix from our vendor. You will need to downgrade your Parallels client if you upgraded it to the 17.1.2868 version over the weekend.

You can remove the current version through control panel:
Type in "Add or Remove Programs" in the search bar on the bottom left of the taskbar.
Scroll until you find "Parallels Client", select it and click uninstall

Then install from the following link. The error is specific to the client build of 17.1.2868

https://download.parallels.com/ras/v17/17.1.1.21792/RASClient-x64-17.1.21792.msi

NOTE: If prompted to upgrade again, choose CANCEL.

Update: Issues with launching remote application connections persist on all client versions, access to desktop sessions are still functional and available for access.
Posted Oct 12, 2020 - 10:22 EDT
Update
If an alert is received regarding your Secure Cloud Services Parallels connection not being secure:

We have identified an issue with the latest version of the Parallels client and are currently awaiting a fix from our vendor. You will need to downgrade your Parallels client if you upgraded it to the 17.1.2868 version over the weekend. You can remove the current version through control panel and install from the following link. The error is specific to the client build of 17.1.2868

https://download.parallels.com/ras/v17/17.1.1.21792/RASClient-x64-17.1.21792.msi

Update: Issues with launching remote application connections persist on all client versions, access to desktop sessions are still functional and available for access.
Posted Oct 11, 2020 - 22:26 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 11, 2020 - 22:25 EDT
Identified
If an alert is received regarding your Secure Cloud Services Parallels connection not being secure:

We have identified an issue with the latest version of the Parallels client and are currently awaiting a fix from our vendor. You will need to downgrade your Parallels client if you upgraded it to the 17.1.2868 version over the weekend. You can remove the current version through control panel and install from the following link. The error is specific to the client build of 17.1.2868

https://download.parallels.com/ras/v17/17.1.1.21792/RASClient-x64-17.1.21792.msi

Update: Issues with launching remote application connections persist on all client versions, access to desktop sessions are still functional and available for access.
Posted Oct 11, 2020 - 15:13 EDT
This incident affected: SWK MCS Data Centers (SWK MCS Data Center West).